【后端开发】phpmyadmin2054错误

【后端开发】phpmyadmin2054错误

后端开发2019-10-21 19:23170ki4网

phpmyadmin2054错误

发生这种错误,是由于MySQL 8默认使用了新的密码验证插件:caching_sha2_password,而之前的PHP版本中所带的mysqlnd无法支持这种验证,需要重新设置一下mysql的密码,因为以前的root密码已经不能使用,所以不能用传统的修改密码方式,而是直接重设密码:

1、 首先修改mysql的配置文件my.cnf

设置任何用户登录都可以获得全部的权限,在[mysqld]的段中加上一句:skip-grant-tables 然后重启mysql

2、 执行修改密码的sql:

UPDATE user SET Password = password ('new-password') WHERE User = 'root';
flush privileges;

3、 再次重启mysql,这下应该就好了

更多PHP相关知识,请访问PHP中文网!

以上就是phpmyadmin2054错误的详细内容,更多请关注ki4网其它相关文章!

炫龙网络 Copyright ©  本站由阿里云强力驱动
【后端开发】phpmyadmin2054错误