【后端开发】ecshopphp版本错

【后端开发】ecshopphp版本错

后端开发2019-10-20 21:34110ki4网

解决方法一:

php 5.3以上版本的问题,和配置有关 只要418行把这一句拆成两句就没有问题了。

将下列:

$tag_sel = array_shift(explode(' ', $tag));

修改为:

$tag_arr = explode(' ', $tag); $tag_sel = array_shift($tag_arr);

因为array_shift的参数是引用传递的,5.3以上默认只能传递具体的变量,而不能通过函数返回值

解决办法二:

找到文件:include/cls_template.php

将以下代码:

return preg_replace("/{([^\}\{\n]*)}/e", "\$this->select('\\1');", $source);

修改成:

return preg_replace_callback("/{([^\}\{\n]*)}/", function($r) { return $this->select($r[1]); }, $source

推荐教程:PHP视频教程

以上就是ecshopphp版本错的详细内容,更多请关注ki4网其它相关文章!

炫龙网络 Copyright ©  本站由阿里云强力驱动
【后端开发】ecshopphp版本错